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On the Use of ImageJ Segmentation 

A. C. Sparavigna1  

1 Dipartimento di Scienza Applicata e Tecnologia, Politecnico di Torino, Torino, Italy

Many methods for the image segmentation are based on thresholding, that is on the conversion of

images into black and white ones. Actually, after the thresholding, it is easy to identify the black or

white domains and calculate the features of them. Of course, it is necessary to write instructions for

the processing of a digital image into a programming language. This task could be beyond the skills

of the user or the scope of user's investigation. In this case, a method based on software ImageJ can

be the simplest approach for the considered research. However, this method needs to be properly

applied. 

Keywords:  Image Processing, Image Segmentation. 

Introduction  In the image processing a segmentation is a method of partitioning an image into

multiple segments, which consist of sets of pixels. These segments are also known as image objects

or super-pixels. Many can be the goals of segmentation; basically they consist in extracting features

by the image representation into the set of segments.  Among the image segmentation methods, we

have also those which are devoted to the determination of the contours of objects; in this case, the

segmentation  is  known as  an  edge  detection  (on  image  segmentation  and edge detections,  see

Refs.1-14).

Many methods of segmentation are based on the thresholding of the image. That is, the image -

made by grey pixels for instance - is converted into a black and white image, by choosing a specific

value of grey (the threshold). The pixels having a grey tone with a value larger than that of the

threshold are converted into white tones, whereas the pixels having a grey tone lower or equal to

the threshold are converted into black pixels. Once the image is converted in this manner, the black

or the white domains, that is the super-pixels, can be identified, that is labelled, by means of an

integer or a colour. Of them we can evaluate centre, area, perimeter and other geometrical features,

as explained in [15,16]). In Ref.15 it is explained the process of labelling the super-pixels.

An approach based on thresholding is very useful for investigating the images of vesicular textures,
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that is the textures that we can observe in materials having inside a distribution of pores [15]. In

particular,  in 2017 the method was applied for the measurement of the pore size distribution of

freeze-dried  solutions,  as  observed  by  means  of  images  obtained  by  the  scanning  electron

microscopy [17,18]. The presence of pores is due to ice crystals. The results of the segmentation

technique  show  a  good  agreement  with  a  model  prediction  of  the  original  ice  crystal  size

distribution, based on balance equations. 

Other  applications  are  given in  [19-29].  In  Refs.  16-29,  the  segmentation  was obtained by the

proper  logic  instructions  written  in  Fortran  77  programming  language.  The  result  of  the

segmentation was rendered in images where each super-pixel has a different colour (see Figure 1).

Figure 1: On the left a fly ash micrograph (courtesy Wikipedia and user Wabeggs), made by means of

a scanning electron microscope (SEM) and back-scatter detector.  On the right,  the related image

segmentation (see Ref.22).

Figure  2:  Distribution  of  the  cross-sections  of  particles  (we  have  not  considered  the  two  largest

irregular particles (green and pale green) of the Figure 1. The area are spaced in intervals of 10 pixels. 
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After the segmentation, we can analyse the distribution of particles. For instance, we can obtain the

distribution of the cross-sections of the particles of the Figure 1, and obtain the result given in the

Figure 2.

The “everything has been done” trap Of course, the best condition for any image segmentation is

that of having a program, in which the instructions can be changes and adapted to the specific

problem under investigation (that was the case for the studies proposed in Refs.15-29). However, to

write the instructions for the processing into a programming language is a task that could be beyond

the skills of the user or the main scope of user's investigation. In this case, a method based on

software,  such as ImageJ,  can be the simplest  approach for the considered  research,  extracting

information  about  the  features  of  super-pixels  from  the  set  of  measurements  that  software  is

proposing. Some references on ImageJ are [30-47].

The number of publications on ImageJ and related tools is huge and it continues to grow. So it

seems that any work on image segmentation can fall into the “everything has been done” trap.  This

is not true. Let us stress that, first of all, it is important to understand the methods of segmentation,

even the starting point of it, that is the thresholding, such as that used in ImageJ, and the labelling of

segments. On the basis of [15], we can imagine different approaches to thresholding and labelling;

these steps are depending on the objects  that we are considering and studying. As it  is easy to

understand, a large difference in the results can be produced by a different thresholding, then a tip

to get past the “everything has been done” trap is to perform a different thresholding and analyse

the different results that we can obtain, because the use of ImageJ is a part of any study that we can

make on images and not the whole. 

ImageJ Let us consider the use of software ImageJ, with the image on the left in the Figure 3. It is a

courtesy  of  Dr.  Mae  Melvin,  USCDCP,  showing  a  photomicrograph  of  a  blood  smear  with

erythrocytes and malaria plasmodium parasites.  After the image is uploaded, the first processing

that we have to make is its thresholding. The suggested approach is that of change the colour image

into an image having pixels in grey tones, and upload the grey-tome image, such as that in the

middle of the Figure 3. The grey-tone image has been obtained by means og GIMP, the GNU Image

Manipulation Program. Then, let us make the thresholding of this image, by means of the ImageJ

instruction sequence Image > Adjust > Threshold. The result is given on the right of the Figure 3,

for the default value of threshold. Let us note that we can make the thresholding using GIMP too.

Moreover, a preprocessing of the image is often required, before any segmentation process we can
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imagine. The micrograph in the Figure 3 on the left is a special case, because it is not requiring any

specific preprocessing for being segmented.  

Figure 3.

After the black and white has been obtained, we have to make it binary for ImageJ. We use the

following sequence of instructions: Process > Binary > Make Binary.  That is, we make it truly

binary for ImageJ. We have the image that software can analyse. The segmentation is obtained by

means of the following sequence of instructions: Analyze > Analyze Particles. The result is given in

the Figure 4. The domains on edges can be excluded as in the given image. Each domain is shown

by means of an outline (but other options are possible). It is labelled by means of an integer, as we

can see in the Figure 4. In a panel, which can be saved in a file, corresponding to each label, we can

find the area of the super-pixel and the coordinates of its centre.

 Figure 4.
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Figure 5.

As we can see in the Figure 4, two large particles are not counted. That is the number of cells is 30

instead of 32. The count is affected by an error of 6%. The particle not counted are shown encircled

in red in the Figure 5. The problem is that two black pixels are joining the cell to that which is

above. We can try to adjust the value of the threshold in order to reduce the area of the objects, and

have in this manner,  the cells  separated.  However,  a different thresholding method or a further

control on the labelling of the particles will help to avoid such a problem. 

Colour segmentation If we try to apply the Particle Analyzer on RGB images, a panel tells us the

these images must be thresholded using Image > Adjust > Color Threshold.  So, in the case of the

Figure 2 on the left, let us try to make the segmentation of the colour image. After adjusting by

means of the Color Threshold, with the default method, we can obtain the segmentation as in the

Figure 7.

Figure 6. 
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The two large domains, that in the previous approach (see Figure 5) have not been counted,  are

visible in the colour segmentation of the Figure 6. However, in the Figure 6, we can see that we

have also a lot of small domains. These domains can be relevant or not, but this is depending on the

specific features that we have to consider. 

In  the  segmentations  that  we  have  shown,  the  cells  containing  the  plasmodium  parasites  are

considered as equal to those which are not infected.  Therefore, a different processing is required to

determine the presence of the parasites.  For what concerns the automated detection of malaria from

blood smear, and other related problems, let us suggest Ref.48.

Different  thresholds   The  ImageJ  Threshold  Color  possesses  several  thresholding  methods.

Among them we find the Default, MaxEntropy, Otsu, and so on. The results that we obtain are

different, besides being dependent on the value of the threshold.

For  instance,  if  we  use  the  Otsu  method  of  thresholding,  an  image  that  we  can  use  for  the

segmentation is like in the Figure 7. 

Figure 7.

Again,  we can see that  one of the particle  is  lost  in  the count.  And the areas  occupied by the

particles are different.

About  the  thresholding,  the  web  page  https://imagej.net/Thresholding#FAQ

(http://archive.ph/mM3DB)  is  proposing  the  following  question:  "How do  I  know whether  my

threshold is correct?", and the answer is this: "In short, you can't. It will always be, to some extent,

in  the  eye  of  the  user/observer/scientist  and  will  also  be  impacted  by  empirically  collected

knowledge. The basic problem of deciding if a threshold (or in general an extraction method) is
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"good" needs a "ground truth".  But such a ground truth is  not naturally  existing and is  always

created in one or the other way by a human. So, describing which method you use—and/or showing

a comparison with other methods—is probably the best you can do to enable a statement on the

quality of the extraction."

Directions For  what  concerns  the  measurements  that  ImageJ  software  is  providing,  they  are

available using  Analyze > Set Measurements. Let us consider a specific measurement (we can find

all the details at the following link: https://imagej.nih.gov/ij/docs/menus/analyze.html )- And it is

the following: we want to determine the directions of rod-like particles. In [27,28], the approach

was based on the calculus of momenta of inertia, and the R-language has been used. Here, let us use

ImageJ and the command Fit Ellipse, which is rendering a rod-like object as an ellipse. At the link

given above, we find the following detail: "Fit Ellipse - Fit an ellipse to the selection. Uses the

headings Major, Minor and Angle. Major and Minor are the primary and secondary axis of the best

fitting ellipse. Angle (0-180 degrees) is the angle between the primary axis and a line parallel to the

x-axis of the image. The coordinates of the center of the ellipse are displayed as X and Y if Centroid

is checked. Note that ImageJ cannot calculate the major and minor axis lengths if Pixel Aspect

Ratio in the Set Scale dialog is not 1.0." An example. 

     

Figure 8.

                                                                            Figure 9.
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We can use the data provided by ImageJ to have the angular distribution of the rod-like object

(Figure 9). The result of the distribution depends on the chosen angular interval.

Discussion The two images that we have used here are quite "good" images. Usually, it is not so.

So we have to be very careful in applying software and the several methods it is offering.

Actually, ImageJ is a powerful software for the segmentation of image. However, and this is true

for any software based on thresholding that we can use, the result depends on the threshold that we

decided to have the binary image. Then, the final results, such as the number of particles and other

related measurements, are linked to the value of the threshold. The example proposed in the Figures

4 and 6 is clearly showing this fact. Therefore we have to estimate carefully the uncertainty of the

count of particles, in particular when this uncertainty is larger than that requested by the case study.

Let  us  stress  once  more  that,  because  of  the  dependence  on  thresholding,  we  have  not  to  be

surprised  that  measurements  can  change  depending  on  the  preprocessing  of  the  image.  The

difference, in percentage, can be relevant or not and this depends on the problem under study. 
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